Zum Inhalt

Prüfe Datenbank-Anbindung zum Oxid-Shop

das WaWi für den Oxid-eShop – die kostenlose Basisversion Foren Forum / Support Prüfe Datenbank-Anbindung zum Oxid-Shop

Dieses Thema enthält 9 Antworten und 4 Teilnehmer. Es wurde zuletzt aktualisiert von  windes vor 1 Monat.

Ansicht von 10 Beiträgen - 1 bis 10 (von insgesamt 10)
  • Autor
    Beiträge
  • #1288

    DCT
    Teilnehmer

    Hallo,

    ich versuche gerade ihr WaWi local auf meinen Rechner zum Testen zu installieren.
    Soweit ist alles gut, doch nach Eingabe der Daten für die Datenbankverbindung bleibt das Setup stehen mit der Meldung „Prüfe Datenbank-Anbindung an Oxid-Shop“, darunter die Meldung „lade bootstrap …“

    In der DB werden auch keine Tabellen angelegt.

    Was kann ich machen? Gibt es ein Skript, womit ich die Tabellen manuell erstellen kann?

    #1289

    Hartmut Hoffmann
    Keymaster

    gibt es in dem WaWi-Verzeichnis eine Datei __errorlog.txt ?

    #1290

    DCT
    Teilnehmer

    Nein, es gibt keine „__errorlog.txt“!

    #1291

    Hartmut Hoffmann
    Keymaster

    hat Setup im WaWi-Verzeichnis eine config.inc.php erstellt?
    ich vermute dass dort wegen der lokalen Installation einige Angaben nicht passen.

    #1292

    DCT
    Teilnehmer

    eine config,inc.php wurde erstellt, der Inhalt ist wie folgt:

    <?php
    /*
    * configuration for WaWi
    *
    * @link http://www.patchwork.de/wawi
    */

    // WaWi database information
    $this->myHost = ‚localhost‘; // database host name
    $this->myName = ‚patchwork‘; // database name
    $this->myUser = ‚xxx‘; // database user name
    $this->myPwd = ‚xxx‘; // database user password
    $this->myType = ‚mysql‘;

    $this->sShopDir = ‚/Users/xxx/Sites/oxid/wawi/../‘;

    // UTF-8 mode in wawi: 0 – off, 1 – on
    $this->iUtfMode = 1;
    // for the following settings do NOT use subdomains!
    global $sWawiUrl;
    $sWawiUrl = ‚https://oxid/wawi/‘; // WaWi base url, required
    global $internetadresse;
    $internetadresse = ‚https://oxid/‘; // with / at the end !

    #1293

    Hartmut Hoffmann
    Keymaster

    die Variablen $sWawiUrl und $internetadresse müssen geändert werden (nicht https… sondern wahrscheinlich c://,,,)
    grundsätzlich macht die lokale Installation keinen Sinn!

    #1319

    milhouse
    Teilnehmer

    Hallo,
    ich habe hier das gleiche Problem.
    Könnte es vielleicht sein, dass es Probleme mit php7.1 und dem dazugehörigen ioncubeloader gibt?
    Gruß
    Manuel

    #1320

    Hartmut Hoffmann
    Keymaster

    die aktuelle WaWi-Version unterstützt bis PHP7.0
    Eine Version für PHP7.3 ist in Vorbereitung

    #1321

    milhouse
    Teilnehmer

    OK. Dann solltet ihr das „Es ist auch bis PHP 7.2 kompatibel.“ mal ändern 😉

    #1335

    windes
    Teilnehmer

    Ich bekomme die Wawi unter 7.1 nicht zum Laufen. Da ja fast auf jedem Hostingpaket 5.6 , 7.0 und 7.1 demnächst abgeschaltet wird. Wird es da früher oder später zu Problemen kommen!
    Gibt es Aussichten auf einen Termin für 7.3. Mein Ioncube ist kompatibel mit 7.1

Ansicht von 10 Beiträgen - 1 bis 10 (von insgesamt 10)

Du musst angemeldet sein, um auf dieses Thema antworten zu können.